SstEndpointUnreachableError(ENOBUFS (10055): No buffer space

VA Smalltalk is a "100% VisualAge compatible" IDE that includes the original VisualAge technology and the popular VA Assist and WidgetKit add-ons.

Moderators: Eric Clayberg, wembley, tc, Diane Engles, solveig

SstEndpointUnreachableError(ENOBUFS (10055): No buffer space

Postby waynej » Fri Oct 17, 2008 11:42 am

Sorry, this is way back in VAST 5.5.2, on a Windows box. That error message sure seems like a resource problem, but the machine seems healthy other than our headless service indicating the above or another error below. Is the problem just too many sockets in use, and is there any way to see the current socket usage other than by the likes of 'netstat -b', or what the maximum number of sockets is? [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters] contains no "TcpNumConnections" parameter.

The immediate problem is that on restarting our headless service after the above, is that we can't start an RMI naming service:

SstApplicationContext class>>#createRmiNamingServiceAt:
receiver = SstApplicationContext
arg1 = rmi://:1099
temp1 = SstLocalEndpoint(invalid,rmi://:1099)
temp2 = 'RMI Naming@rmi://:1099'
temp3 = SstInternalTransportError(EACCES (10013): Permission denied)
temp4 = rmi://:1099

Our usual advice worked - reboot the machine enough times and that latter problem will go away - though I forget the exact error we'd seen in the past when starting up an RMI naming service. But I just thought this might be related to the ENOBUFS which we never saw before.
Posts: 32
Joined: Wed Apr 18, 2007 9:18 am

Re: SstEndpointUnreachableError(ENOBUFS (10055): No buffer space

Postby marten » Mon Oct 20, 2008 1:01 pm

I've looked for that and there are numerous answers to this error: from malware, trojaners, "full" IE folder and all that stuff - but actually I would try this answer I've found:

If you are running Windows NT/2000/XP follow these steps: First step is to launch the registry editor. To do this go to Start, Run and type regedit. In the left pane navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters once there, you must create the entry TcpNumConnections. To do this, right click in the right pane and choose new from the menu and select DWORD Value. Give it the name TcpNumConnections. Then right click it and select modify and enter a value of 200.

Restart your computer, if all goes well then you fixed the problem, if not, revert the changes by restoring the registry. (You may have to reboot to safe mode to do this).

But that this is not the only parameter can be read here:
Marten Feldtmann, Principal Smalltalk User, Private
SkypeMe callto://marten.feldtmann
Posts: 641
Joined: Sat Oct 14, 2006 7:10 am
Location: Hamburg - Germany

Return to VA Smalltalk 7.0, 7.5 & 8.0

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest