Error 108

VA Smalltalk is a "100% VisualAge compatible" IDE that includes the original VisualAge technology and the popular VA Assist and WidgetKit add-ons.

Moderators: Eric Clayberg, wembley, tc, Diane Engles, solveig

Error 108

Postby rwbeukema » Thu Sep 20, 2007 4:13 am

The error message is:

Error: 108 Cannot make edition of GrainFactor in Cusum because GrainFactor is not visible.

As far as I can tell, here is the sequence that leads up to this:

The class GrainFactor appears to be fine in the browser, status bar says "GrainFactor 2.1 (defined) in Cusum". If I change an instance method and save it, status for the instance method becomes "Undefined from Unknown in 'Not Categorized'". After that, further attempts to change methods yield the above error message.

"make image consistent" reveals no issues either before or after.

Probably related to this: when I first packaged the Cusum application after upgrading to 7.5.1, it decided to exclude the GrainFactor class and its subclasses. I eventually added a "packagerIncludeClassNames" method to the Cusum application class.

No other classes experience either one of these problems. I've tried migrating back to 7.5 and forward to 7.5.2 both via import/export into empty libraries and via file out/file in. The problem reappears even with clean installations of each version.

The application has 131 classes, has been under active development for years on OS/2, Windows and Linux. The library is accessed from the file system since I'm the only developer. I do work on multiple machines in various locations and transport the code by exporting and importing.

The Windows development environment is at 6.0.3 and OS/2 is at 6.0.1. All code is developed on the Linux machine (7.5 and counting) and pushed to the others for packaging.

It's perfectly possible that I did something stupid and it's been following me around ever since but for the life of me I can't find it. It's been an issue for a couple of months and every time I think I've fixed it, it comes back again.

Soooo - I thought it would be worth posting just in case it's not me!

Thanks to anyone who can shed some light on this...

Posts: 4
Joined: Mon Jan 08, 2007 11:57 am

Re: Error 108 - it's fixed...

Postby rwbeukema » Fri Sep 21, 2007 4:51 am

Apparently the problem started when I added an instance method #hasController. The potential for conflict with ClassDescription >> hasController was there but evidently I didn't notice the collision.

At any rate, the answer to #hasController is used to determine whether a class is visible to an application. I first noticed the problem in 7.5.1 when my class started getting excluded by the packager. I was too quick to blame it on a version change, and in too big a hurry to research the cause of the problem!

It wasn't until much later when I needed a new edition of the class that I realized the full scope of the problem.

As I feared, I did it to myself! If I call it a learning experience, will that ease the pain?
Posts: 4
Joined: Mon Jan 08, 2007 11:57 am

Postby bpieber » Sat Sep 22, 2007 12:28 am

Thanks for sharing this. I might have fallen into the same or a similar trap. You should be glad that you found it.

Posts: 27
Joined: Sat Nov 04, 2006 4:00 am

Return to VA Smalltalk 7.0, 7.5 & 8.0

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest