64-Bit issues with WindowTester

WindowTester allows you to easily create and run unit tests for every GUI they build. It can also be used to generate system level tests.

Moderators: gnebling, Eric Clayberg, Dan Rubel, keertip, Phil Quitslund

64-Bit issues with WindowTester

Postby mrueegg » Tue Nov 23, 2010 4:28 am


When I use WindowTester on my workstation (32-Bit Ubuntu) my tests run successfully. But as soon as I run them on my CI environment (Ubuntu 64-Bit server) I get the following exception:

Caused by: java.lang.RuntimeException: Failed to create widget reference for instance of org.eclipse.swt.widgets.Menu
WindowTester: 201009131510 - linux,gtk,x86_64

I've read in another post that WindowTester currently doesn't support 64-Bit. That's kind of a showstopper for me. Somebody has mentioned that it's possible to use v3.9 on 64 Bit. Is that true? If yes, is there a p2 repository for WindowTester v3.9? I run my tests with Maven/Tycho and in order to properly install WindowTester I need to have a p2 repository.

Thanks a lot in advance,
Posts: 1
Joined: Tue Nov 23, 2010 4:11 am

Re: 64-Bit issues with WindowTester

Postby keertip » Tue Nov 23, 2010 12:46 pm

The current version of WindowTester does not have support for 64 bit linux. We will look into v3.9 and 64bit support and post an update.
Posts: 221
Joined: Thu Mar 15, 2007 10:26 am

Return to Window Tester

Who is online

Users browsing this forum: No registered users and 1 guest