Playback: mouse move increments delay for part of code

WindowTester allows you to easily create and run unit tests for every GUI they build. It can also be used to generate system level tests.

Moderators: gnebling, Eric Clayberg, Dan Rubel, keertip, Phil Quitslund

Playback: mouse move increments delay for part of code

Postby manikanti » Wed Jul 15, 2009 10:30 pm

I have code fragment something like this

new MenuItemLocator("Window/Sub option A/ Sub Sub option B/Sub Sub Sub option C");

When i manually do the clicks, option B and C are opening is little slow. And i do not have have any way to make it fast. Reply of recorded test is opening till Option A and exiting. I tried changing "Window->Preferences->Playback->Delay->Delay between mouse move increments (in milliseconds) to 200. Replay is successful. But this is delaying all of the test cases in the execution, there are about 30, all 30 test cases execution is getting delayed to increase in move increments delay.

Is there any way, I can increase the delay only for part of the code, for example:

......
increase mouse increment delay
new MenuItemLocator("Window/Sub option A/ Sub Sub option B/Sub Sub Sub option C");
reset mouse increment delay
......

Thanks,
-Sreedhar Reddy
manikanti
 
Posts: 12
Joined: Tue Jun 16, 2009 8:06 pm

Re: Playback: mouse move increments delay for part of code

Postby Phil Quitslund » Thu Jul 16, 2009 8:54 am

There is currently no API to programmatically alter playback settings. That said, I wonder if this is even what we want to do... Wouldn't it be better if you did not need that special handling for that menu? Could you post the stacktrace produced when you try and run the test without delay on?
--
Phil Quitslund
Software Engineer
Google, Inc.
Phil Quitslund
Moderator
 
Posts: 491
Joined: Fri Apr 28, 2006 6:26 am


Return to Window Tester

Who is online

Users browsing this forum: No registered users and 1 guest