Just thought people should be aware of this:
a)I created a JList object, which had the default name 'list'.
b)I changed the name to something useful, i.e, "rateList".
c)My code suddenly grew errors.
When I checked the code, I found that a call to file.list() had become a call to file.rateList().
Probably a good idea to make sure the default names for Java controls aren't used as function calls as well.
I am using Designer 6.4.1